Introduction to Ruby Programming

Introduction to Ruby Programming

Foothill-De Anza Community College District

$95.00 Enroll Now!

Instructor-Led Course
Hours: 24
Duration of Access: 6 weeks
Start Dates: Aug 20, Sep 17, Oct 15, Nov 12
1,359 Students
have taken this course.

Requirements

• Internet access
• Email
• One of the following browsers: 
    o Mozilla Firefox 
    o Microsoft Internet Explorer (9.0 or above)
    o Google Chrome
    o Safari
• Adobe PDF  plug-in (a free download obtained at Adobe.com .)

 

A Ruby on Rails software development environment is required for this course. The first lesson walks through installing a Rails environment on a Windows PC using the Rails Installer software package. The Rails Installer package can be downloaded from railsinstaller.org. You must have a Windows NT, Windows 2000, Windows XP, Windows Vista, or Windows 7 workstation, or a Windows NT, Windows 2000, Windows 2003, or Windows 2007 server to install the Rails Installer package. Please note that Rails Installer does not work on Windows 95, Windows 98, nor Windows Me. Students using the Macintosh platform may be able to use the default Ruby environment included on Macintosh OS X 10.4 (Tiger), 10.5 (Leopard), 10.6 (Snow Leopard) and 10.7 (Lion). Please consult the Apple Web site for instructions on how to update the installed software to the latest version of Ruby on Rails. Prior HTML coding experience is helpful; but not required.

Review

The Instructor quickly answered my questions. I was truly able to maximize my learning.

Follow Us